E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP - Fuse for E1

Welcome, Guest. Please login or register.
Did you miss your activation email?
June 26, 2017, 06:54:32 PM
Home Help Search Login Register
News: Want to register? Then please don't use a Hotmail, Yahoo or Gmail address. They'll block the activation email.
Still having problems activating your account? Send an email to: EIII @ telenet.be

+  E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP
|-+  General Category
| |-+  EI Technical Issues / Tips
| | |-+  Fuse for E1
« previous next »
Pages: [1] Print
Author Topic: Fuse for E1  (Read 1524 times)
Mr.L
Newbie
*
Offline Offline

Posts: 7


« on: April 23, 2013, 06:21:40 AM »

Last night, I tried to power up my E1 first the first time since buying my EIII in 1988.

Unfortunately, the fuse is missing. Any one know what size/kind of fuse I need?

Also...it's been a long time. Is the E1 operating system on a separate disk, or embedded on all of the disks?

I want to evaluate the condition of the unit before selling it.

Thanks,

Mr.L

Logged
Mr.L
Newbie
*
Offline Offline

Posts: 7


« Reply #1 on: April 23, 2013, 06:51:51 PM »

Answered my own questions.

Looks like a 7A 125V fuse.

The original manual states: "Each diskette also contains the Emulator's complete operating program."

Thx.

Mr.L
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP - Fuse for E1

SEO light theme by © Mustang forums. Powered by SMF 1.1.21 | SMF © 2015, Simple Machines