E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP - E1 owners help...please????

Welcome, Guest. Please login or register.
Did you miss your activation email?
August 21, 2017, 08:55:27 AM
Home Help Search Login Register
News: Want to register? Then please don't use a Hotmail, Yahoo or Gmail address. They'll block the activation email.
Still having problems activating your account? Send an email to: EIII @ telenet.be

+  E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP
|-+  General Category
| |-+  EI Technical Issues / Tips
| | |-+  E1 owners help...please????
« previous next »
Pages: [1] Print
Author Topic: E1 owners help...please????  (Read 1249 times)
Mr.L
Newbie
*
Offline Offline

Posts: 7


« on: July 22, 2013, 02:49:37 PM »

My E1 is being refurbished and will eventually be put up on eBay.

It's missing its fuse. There's no indication in the machine, or in the manual and schematic what value / size /amps etc the fuse should be.

Can any one who owns an E1 please let me know what size fuse I need?

Thanks,

Mr.L
Logged
esynthesist
E-mu Software God
Sr. Member
*****
Offline Offline

Posts: 419


« Reply #1 on: July 23, 2013, 01:37:22 PM »

My Emulator-I has a 2 AMP glass tube fuse of 1 1/4 inch in length and 1/4 inch in diameter; no voltage spec; the only other thing mentioned on the paper in the tube is "Radio / Charger", so it's a "2 AMP Radio / Charger" fuse.

I can't guarantee though that it's the original fuse and whether it has the appropriate current specification.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP - E1 owners help...please????

SEO light theme by © Mustang forums. Powered by SMF 1.1.21 | SMF © 2015, Simple Machines