E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP - EII+ HD with a Dead FDD and dead HDD

Welcome, Guest. Please login or register.
Did you miss your activation email?
December 17, 2017, 01:12:35 AM
Home Help Search Login Register
News: Want to register? Then please don't use a Hotmail, Yahoo or Gmail address. They'll block the activation email.
Still having problems activating your account? Send an email to: EIII @ telenet.be

+  E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP
|-+  General Category
| |-+  EII Technical Issues / Tips
| | |-+  EII+ HD with a Dead FDD and dead HDD
« previous next »
Pages: [1] 2 Print
Author Topic: EII+ HD with a Dead FDD and dead HDD  (Read 550 times)
Paula
Jr. Member
**
Offline Offline

Posts: 17


« on: June 25, 2017, 10:22:24 AM »

So I'm repairing this EII+ HD for someone, this has quite a lineage and is well worth the effort.
I've found the reason the PSU got fried, and replaced the faulty part on the Output Board. New PSU is on it's way to me and it boots from my Bench supply. So I'm making progress.

It's been in storage for 20+ years and not touched, sadly, it has rusted a bit.
in particular the FDD and HDD have suffered from Rust.
(I couldn't work out how to upload pictures)

the FDD is a Panasonic JU-465-5
the HDD is a miniscribe 8425

My thoughts;
Get a new FDD
Remove HDD
Install one of the HxC adapters as a second floppy drive.

Questions;
Where can I buy a new FDD? The one I found on ebay as £174!
Are there alternative FDDs that work? if so does anyone have model numbers?
Are there any HDD emulators that would work?
A few people have installed the HxC adapters, looks pretty straight forward but are there any 'gotchas' to be wary of?

Finally, if I'm removing the HDD, will it boot from a FDD? or will it always try and boot from HDD?
Logged
Wolfram
Full Member
***
Offline Offline

Posts: 100


« Reply #1 on: June 25, 2017, 02:08:32 PM »

Buying a new Floppy Drive makes no sense.
Just put a HxC in it to boot and use a EMuSer to load sounds.
Logged
who
Full Member
***
Offline Offline

Posts: 197


« Reply #2 on: June 25, 2017, 07:10:13 PM »

I agree.  About the only reason you need the original drive is if you have a custom library on floppy.
Logged
Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #3 on: June 25, 2017, 10:24:52 PM »

Thanks, this one used to belong to Midge Ure from ultravox and I was hoping to get sounds off the HDD, or from the floppy library.
However it seems that there are no floppies, so replacing the FDD with an HxC and removing the HDD.

Question;
Can I leave the Adaptec card in there, without a HDD, and still boot from the HxC?
Could someone supply me with the boot image file needed for the HxC SDCard please?

Paula
Logged
alka
Full Member
***
Offline Offline

Posts: 61


WWW
« Reply #4 on: June 26, 2017, 01:00:09 PM »

Paula - the hxc boot files and various instructions for the Emulator II can be found here: http://users.skynet.be/emxp/HXC.htm Replacing the dead FDD with the SD card reader is a great choice... it literally holds thousands of banks.. the only drawback is the navigation of folders on the hxc, it is cumbersome but then again so would swapping out 5.25" disks every time you wanted a new bank loaded...

more info on the sound conversion process for the hxc and some handy EII bank files can be found here: https://www.muffwiggler.com/forum/viewtopic.php?p=1657619

signed your synth-friendly librarian, alka

http://www.magicksquares.com
Logged

Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #5 on: July 12, 2017, 10:39:18 AM »

Hi,

 This is the one I can find online, is this suitable?
http://lotharek.pl/product.php?pid=121

 I've got a 3.5" adapter plate, and cable suitable for replacing the floppy cable in the EII from ebay.

Many thanks in advance
Paula
Logged
alka
Full Member
***
Offline Offline

Posts: 61


WWW
« Reply #6 on: July 12, 2017, 11:28:10 AM »

that's the one! good luck.
Logged

Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #7 on: July 28, 2017, 05:17:06 AM »

Hi,

 So I've got it powering up.
But it won't boot Sad

 On the EII LCD I see ;

*** EMULATOR 2***
Boot in Progress

 On the  HxC emulator, I've put a bunch of things on the SD Card and selected this -
"emuii_os_3_1HD.hfe"
the HxC display shows the name and -

"RA T:000/080 S:1"  which I assume is the current track number (0 of 80) and side (side 1)
Both LEDs are permanently lit, no "clicks" from the HxC

so, I'm wondering, is the EII trying to boot from HDD? if so can I stop it (the HDD is frozen solid).

Do I need load an OS from disk? I was kind of under the impression I did, but maybe I don't?

Any advice very gratefully received (I've never used ans EII before).

Paula
Logged
Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #8 on: July 28, 2017, 05:54:26 AM »

Done some digging, I suspect my EII+ HD is trying to boot from the HDD which is defunct.
So I need to find an EPROM image for a non HD EII+, I notice the latest version seems to be 3.1, does anyone have the file they can share with me? (I have a friend with an EPROM burner).

Many thanks
Paula
Logged
alka
Full Member
***
Offline Offline

Posts: 61


WWW
« Reply #9 on: July 28, 2017, 06:55:53 AM »

Yup.. all EII OS's can be found here: http://users.skynet.be/emxp/Additional_downloads.htm
Logged

Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #10 on: July 28, 2017, 08:01:57 AM »

Alka,

 thanks, but these don't seem to be copies of the EPROM image inside the EII Sad

Paula
Logged
alka
Full Member
***
Offline Offline

Posts: 61


WWW
« Reply #11 on: July 28, 2017, 08:21:40 AM »

oops sorry misread that.. you can find all the EPROM binaries at the yahoo group files section.. you will need to join the group to access: https://groups.yahoo.com/neo/groups/emulatorII-list/files/Technical/EPROM%20Binaries/
Logged

Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #12 on: July 28, 2017, 09:47:48 AM »

Alka,

 Thanks, but I don't have a yahoo account and I really don't what them to have my mobile number.
Is there anyway of getting the file without giving yahoo my mobile?

paula
Logged
alka
Full Member
***
Offline Offline

Posts: 61


WWW
« Reply #13 on: July 28, 2017, 12:10:07 PM »

I don't recall having to put that info in to gain access to the group... hmm... private message me your email.
Logged

Paula
Jr. Member
**
Offline Offline

Posts: 17


« Reply #14 on: August 07, 2017, 11:30:55 AM »

Bit of an update;

 I got a couple of ROM images from Alka (thank you). And sadly that hasn't solved the problem, the LCD still shows "booting" and there is not disk activity on the HxC drive.

 Here's the ROM that is in the EII in the main rom position and also the scanner ROM.
I also removed the adapter board and took the Z80 SIO out and popped it in the slot the adapter board was in (Someone else on here did the same thing).

 has anyone got any suggestions where to start next?
 Has anyone got details of the jumper settings on the HxC (just in case I got them wrong) ?

Many thanks
Paula





* IMG_20170806_0938094.jpg (352.8 KB, 1067x1600 - viewed 22 times.)

* IMG_20170806_0940219.jpg (277.6 KB, 1600x1067 - viewed 20 times.)
Logged
Pages: [1] 2 Print 
« previous next »
Jump to:  


Login with username, password and session length

E-mu Emulator Sampler User Forum for the EIII EII EI and EIII XP - EII+ HD with a Dead FDD and dead HDD

SEO light theme by © Mustang forums. Powered by SMF 1.1.21 | SMF © 2015, Simple Machines